Technical Problem With Launcher

Dear visitor, welcome to the Grand Fantasia Forum.

To use all the features of this page, please create an account or login.

  • I have a problem with the GF launcher, I use a laptop with Windows Vista. I have all the requirements to play it, but at startup (with the US launcher even though I am Italian) it asks me to give consent to some explorer scripts (updated to version 9), after accepting 4 or 5 times loads the initial image of the launcher with the castle and offers. Then clicked "Start" I get "Web page not available" and then I followed various guides from the forum, updated DirectX, C ++ runtimes, explorer, uninstalled all GF with Revo and reinstalled from the official website ... but nothing written remains there. Ah, I tried to copy the link that doesn't find explorer directly on it and the result doesn't change. After doing the same thing on Chrome, various results appear on the aeria games website. Help? ^^ "

  • Hello,

    Have you tried to activate your ssl 2.0 and 3.0 in your internet option under the advanced tab?

    Can you provide us a screenshot of the launcher please !!

    Also, be sure to enter your nickname and password in the launcher, and not in the game as it used to be. If you can't, make sure to use the right launcher cause there's two of them in the folder.

    Keep us updated :)